Technical Requirements

  • Updated

Using Apiax doesn't require the installation of specific Apiax software or hardware. However, to ensure you are ready to use the Apiax products, check if your existing software and tools meet the requirements mentioned in this document.

Web browser

  • Web browser with JavaScript support
  • WebGL activated to use the Rule Editor.
  • One of the following web browsers:
    • Google Chrome v. 92 or higher
    • Mozilla Firefox v. 91 or higher
    • Apple Safari v.14.1 or higher
    • Microsoft Edge v. 92 or higher

Sign-on

For accessing the Apiax Platform and apps:

  • Log in credentials provided by Apiax support.
  • 2-Factor Authentication (2FA) app on your mobile phone. Refer to Setting up the 2-factor Authentication for instructions.
  • Optional: Single Sign-on (SSO) infrastructure supporting OpenId Connect or SAML (Security Assertion Markup Language)

API access

For accessing the API:

  • Https and TLS1.2 encryption for standard access.
  • Email address and a password to get an X.509 certificate, allowing a stronger authentication method (2FA).
  • Specific username and password for technical users.
  • You need to create the SDK for your preferred programming language, use the OpenAPI (Swagger) definition.
  • Your network security policy settings must allow access to the Apiax URLs (*.apiax.io and *apiax.com). Make sure the network firewalls and security controls are not preventing access to Apiax.

Hardware

  • Core i7 processor version 09 or equivalent
  • 16GB RAM
  • 20 GB free hard disk space
  • Web GL 1.2 accelerating Graphics hardware

 

Was this article helpful?

Comments

0 comments

Article is closed for comments.

Still have questions?

Please submit a request and we will get back to you shortly.

Submit a request